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Abstract. Childbirth involves uterine contractions leading to cervix opening. Effective pain management is crucial to 

reduce anxiety, fear, and stress, which worsen pain. This study developed a vibration-based birth aid to 

reduce pain in the first phase of labor.This tool uses a MAX30100 sensor for monitoring vital signs and a 

SW-420 sensor for adjusting vibration at acupressure points. Data is sent to Google Sheets via ESP32. Tests 

on five pregnant women showed that this device needed a slight increase in vibration to prove its effectiveness 

in reducing pain. Using Research and Development (R&D) method with a focus on technology that can 

improve the mother's overall birth experience. The results show that this tool has great potential as a safe, 

economical and effective non-pharmacological method in the management of labor pain. 
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Abstrak. Proses persalinan adalah fenomena alamiah di mana kontraksi uterus menyebabkan  penipisan dan 

pembukaan serviks secara fisiologis. Manajemen nyeri penting untuk mengurangi dampak negatif seperti 

kecemasan, ketakutan, dan stres yang dapat memperburuk intensitas nyeri. Penelitian ini mengembangkan 

alat bantu persalinan berbasis vibrasi untuk mengurangi nyeri pada fase pertama persalinan. Alat ini 

menggunakan sensor MAX30100 untuk memonitor saturasi oksigen, detak jantung, dan tekanan darah, serta 

sensor vibrasi SW-420 untuk mengatur intensitas getaran pada titik akupresur. Data yang terkumpul secara 

otomatis ditransfer ke google sheet melalui mikrokontroler ESP32. Pengujian pada lima ibu hamil 

menunjukkan bahwa alat ini memerlukan sedikit peningkatan pada vibrasinya untuk membuktikan 

efektivitasnya dalam mengurangi nyeri. Penelitian ini menggunakan metode Research and Development 

(R&D) dengan fokus pada teknologi yang dapat meningkatkan pengalaman persalinan ibu secara 

keseluruhan. Hasilnya menunjukkan bahwa alat ini memiliki potensi besar sebagai metode nonfarmakologi 

yang aman, ekonomis, dan efektif dalam manajemen nyeri persalinan. 

Kata Kunci - Persalinan, nyeri, akupresur, alat bantu, vibrasi, R&D 
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I. PENDAHULUAN  

Proses persalinan adalah suatu proses alamiah di mana ibu mengalami kontraksi yang menyebabkan penipisan dan 

pembukaan serviks secara fisiologis[1]. Pada persalinan normal, terjadi nyeri yang bersifat hilang timbul. Sensasi 

nyeri muncul saat kontraksi mencapai puncaknya dan mereda setelah uterus mengalami relaksasi[2]. Nyeri persalinan 

merupakan fisiologis pada proses persalinan dengan intensitas nyeri yang berbeda pada setiap in Nyeri persalinan 

adalah suatu pengalaman fisiologis dengan intensitas yang bervariasi pada setiap individu[3]. 

 Berbagai upaya telah dilakukan untuk mengurangi nyeri pada persalinan, baik melalui pendekatan 

farmakologi maupun nonfarmakologi[4]. Manajemen nyeri secara farmakologi lebih efektif daripada metode 

nonfarmakologi, tetapi metode ini cenderung lebih mahal dan berpotensi menimbulkan efek samping yang kurang 

diinginkan. Di sisi lain, metode nonfarmakologi memiliki keunggulan sebagai pilihan yang ekonomis, sederhana, 

efektif, dan bebas dari efek yang merugikan[5]. Selain itu, metode nonfarmakologi dapat meningkatkan kepuasan 

selama persalinan karena memungkinkan ibu untuk mengontrol perasaan dan kekuatannya[6]. 

 Masalah yang paling umum terjadi pada ibu saat persalinan adalah nyeri. Jika nyeri tidak diatasi, dapat 

menyebabkan kecemasan, ketakutan, dan stres pada ibu, yang kemudian dapat meningkatkan intensitas nyeri yang 

dirasakan. Nyeri bersama dengan ketakutan selama persalinan bisa memperlambat proses tersebut. Nyeri ini dapat 

menyebabkan hiperventilasi, meningkatkan kebutuhan oksigen, menyebabkan alkalosis respiratorik, vasokonstriksi 

pembuluh darah di uterus, dan asidosis pada janin. Peningkatan kadar noradrenalin dapat mengurangi aliran darah ke 

plasenta, mengurangi kontraksi uterus, dan mengganggu keselamatan ibu dan janin serta keberhasilan proses 

persalinan secara pervaginam.[7]  

 Salah satu teknik nonfarmakologi yang sangat efektif dalam manajemen nyeri persalinan adalah 

akupresur[6]. Teknik akupresur dapat mengurangi rasa nyeri dan mempercepat durasi persalinan[8]. Penggunaan 

alat ini bertujuan untuk membantu mempercepat proses persalinan pada tahap pertama tanpa memerlukan pijatan 

manual, karena alat ini menggunakan sistem vibrasi elektronik yang dapat dikontrol intensitas getarannya. Selain itu, 

alat ini juga dapat memantau tekanan darah, saturasi oksigen, dan denyut jantung pasien secara otomatis, dengan 

hasil pengukuran yang terdokumentasi dalam Google Sheet. Hal ini memberikan kemudahan bagi tenaga medis 

dengan menghilangkan kebutuhan pencatatan manual, serta memungkinkan pengawasan kondisi pasien secara lebih 

efisien dan praktis. 

II. METODE 

2.1 Metode Penelitian 

 Metode penelitian yang diterapkan dalam penelitian ini adalah RnD (Research and Development) atau 

Penelitian dan Pengembangan dalam konteks bahasa Indonesia yang merupakan kerangka kerja penelitian yang 

digunakan untuk menciptakan produk tertentu dan menilai efektivitasnya. Penelitian ini mengembangkan dari 

rancang bangun alat bantú persalinan ibu hamil untuk mengurangi rasa nyeri pada kala 1 dengan vibrasi yang sudah 

ada sebelumnya. 

 

2.2 Blok Diagram Sistem 

 Blok diagram sistem menjelaskan proses dari penelitian ini yang mempunyai input, proses dan output.  

Berikut merupakan blok diagram sistem dari penelitian ini. 

 
Gambar 2.2 Blok Diagram Sistem 
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 Gambar 2.1 merupakan blok diagram sistem penelitian ini. Mempunyai 3 inputan yaitu Sensor MAX30100 

sebagai pemantau suhu, detak jantung, kadar gula, dan tekanan darah pasien. Sementara sensor vibration SW-420 

digunakan sebagai pembaca vibrasi pada vibrator. RFID sebagai penampil data pasien beupa nama dan umur yang 

terkoneksi langsung dengan ESP32. Sensor MAX30100 dan sensor vibration SW-420 memberikan masukan analog 

yang kemudian akan diolah didalam mikrokontroler Arduino Uno R3 dan dengan sendirinya arduino membaca sinyal 

sensor MAX30100 dan sensor vibration SW-420 menjadi data digital kemudian ditransfer ke ESP32. ESP32 sebagai 

mikrokontroller yang berbasis IoT akan mengirimkan database dari parameter detak jantung, kadar gula, tekanan darah 

dan suhu pasien ke dalam aplikasi google sheet serta ditampilkan pada LCD I2C 16x2. Terdapat 2 output vibrator 

sebagai alat bantu getar pada titik akupresure yang bisa diatur dengan potensiometer untuk tingkat getarannya. 

 

2.3 Flowchart Sistem 

 Berikut merupakan flowchart sistem dari rancang bangun alat bantú persalinan ibu hamil untuk mengurangi 

rasa nyeri pada kala 1 dengan vibrasi berbasis arduino. 

 
Gambar 2.3 Flowchart Sistem 

 

2.4 Software Arduino IDE 

 Arduino IDE (Integrated Development Environment) merupakan perangkat lunak yang difungsikan untuk 

melakukan pemrograman dan mengunggah program ke papan mikrokontroler Arduino[9]. Dengan menyediakan 

suatu lingkungan pengembangan yang simpel dan bersahabat, Arduino IDE mempermudah pengguna dalam proses 

penulisan, pengujian, dan pengunggahan kode program ke papan Arduino[10]. 
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Gambar 2.4 Tampilan ,Software Arduino 

 Gambar 2.4 menunjukkan tampilan dari software arduino IDE. Langkah-langkah memprogram dan mengunggah 

(upload) program pada Arduino IDE adalah sebagai berikut: 

1. Unduh dan Install Arduino IDE dengan membuka situs resmi Arduino di https://www.arduino.cc/en/software. 

Pilih versi Arduino IDE yang sesuai dengan sistem operasi (Windows, macOS, atau Linux). Ikuti petunjuk 

instalasi yang disediakan. 

2. Setelah instalasi selesai, buka Arduino IDE. 

3. Pilih jenis board mikrokontroler yang akan digunakan. Pilih dari menu "Tools" > "Board" > pilih jenis board 

yang sesuai. 

4. Pilih port serial yang terhubung dengan Arduino. Pilih dari menu "Tools" > "Port" > pilih port yang sesuai. 

5. Buat program (sketch) baru atau buka sketch yang sudah ada. Gunakan menu "File" > "New" untuk membuat 

sketch baru atau "File" > "Open" untuk membuka sketch yang sudah ada. 

6. Tulis atau tempelkan program ke dalam area kerja Arduino IDE. 

7. Klik tombol "Verify" atau "Checkmark" (✔) untuk memeriksa apakah program tidak mengandung kesalahan 

sintaksis. 

8. Klik tombol "Upload" (ikon panah ke kanan) untuk mengunggah program ke papan Arduino. 

9. Tunggu sampai proses upload selesai. Pada akhirnya, akan melihat pesan "Done uploading"[11]. 

 

2.5 Google Sheet dan Apps Script 

 Google Sheets adalah layanan spreadsheet berbasis cloud yang disediakan oleh Google. Ini memungkinkan 

pengguna untuk membuat, mengedit, dan berbagi lembar kerja secara online[12]. Google Apps Script, di sisi lain, 

adalah platform pengembangan skrip yang terintegrasi dengan produk-produk Google, termasuk Google Sheets. 

Google Apps Script memungkinkan pengguna untuk membuat skrip yang dapat otomatis mengotomatisasi tugas di 

Google Sheets dan aplikasi Google lainnya[13]. 

 

 

 

https://www.arduino.cc/en/software
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Gambar 2.5 Tampilan Apps Script pada Google Sheet 

 Gambar 2.5 menunjukkan tampilan apps script pada google sheet. Untuk membuat program Apps Script yang 

terkoneksi dengan ESP32, langkah-langkah umumnya melibatkan penggunaan Google Apps Script untuk membuat 

layanan API web, yang kemudian dapat diakses oleh ESP32 untuk berkomunikasi dengan Google Sheets atau aplikasi 

Google lainnya. Berikut adalah panduan umumnya[14]: 

1. Buka Google Drive https://drive.google.com/ dan pastikan masuk ke akun Google yang sesuai. 

2. Buat spreadsheet baru atau buka yang sudah ada dan beri judul sesuai project. 

3. Dari menu spreadsheet, pilih "Extensions" > "Apps Script". 

4. Hapus kode yang ada di editor dan gantilah dengan kode baru yang sesuai dengan kebutuhan 

5. Dalam skrip Apps Script, buat fungsi yang mengembalikan data dalam format JSON. 

 Berikutnya adalah mengkonfigurasi antara ESP32 dengan Apss Script melalui software arduino IDE[15]. 

1. Pastikan ESP32 terhubung dengan internet dan Anda telah menginstal library WiFi dan HTTPClient di Arduino 

IDE. 

2. Buka Arduino IDE dan buat program untuk ESP32. 

3. Gunakan HTTPClient untuk membuat permintaan GET ke URL yang telah disalin dari layanan API web Google 

Apps Script. 

4. Hubungkan ESP32 ke komputer dan pilih board serta port serial yang sesuai di Arduino IDE. 

5. Buka Serial Monitor untuk melihat output data yang diambil dari Google Apps Script. 

 

2.6 Rangkaian Keseluruhan Alat 

 

 
Gambar 2.6 Rangkaian Keseluruhan Alat 

 Gambar 2.6 merupakan rangkaian keseluruhan alat dari alat bantú persalinan ibu hamil untuk mengurangi 

rasa nyeri pada kala 1 dengan vibrasi berbasis arduino. Mempunyai input sensor suhu MAX 30100 dan sensor 

vibration SW-420 lalu diproses dengan arduino uno dan RFID-RC522 diproses ESP32 dengan output penampil 

manual LCD I2C 16x2 dan  module vibrator. Untuk lebih jelasnya dapat dilihat pada tabel di bawah ini. 

https://drive.google.com/
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Tabel 2.6 Pengalamatan Pin Rangkaian Keseluruhan 

No. Nama Hardware Pin Hardware Nama Hardware Pin Hardware 

1. 

Arduino Uno R3 

5V 

Sensor MAX30100 

VIN 

2. GND GND 

3. A5 SCL 

4. A4 SDA 

5. 5V 
Sensor Vibratiom 

SW-420 

VCC 

6. GND GND 

7. 10 DO 

8. GND 

LCD I2C 16x2 

GND 

9. 5V VCC 

10. SDA SDA 

11. SCL SCL 

12. 5V 

ESP32 

VIN 

13. GND GND 

14. 2 D34 

15. 3 D35 

16. GND Power Bank - 

17. VIN 
Switch 

2 

18. Power Bank + 1 

19. 

Vibrator 1 

GND 
ESP32 

GND 

20. VCC VIN 

21. IN 

Potensiometer 

2 

22. 
ESP32 

GND 1 

23. D22 3 

24. 

Vibrator 2 

IN 2 

25. VCC 

ESP32 

VIN 

26. GND GND 

27. 

RFID-RC522 

+3.3V 3V3 

28. RST D21 

29. GND GND 

30. MISO D19 

31. MISI D23 

32. SCK D18 

33. SDA D5 

 

 

2.7 Pengujian Alat 

Tahap pengujian alat terbagi menjadi 2 yaitu: 1) pengujian sistem perbagian 2) pengujian keseluruhan alat 

 

2.7.1 Pengujian Sistem Perbagian 

Tahap ini dilakukan untuk pengujian setiap komponen yang digunakan, apakah komponen tersebut 

sudah berfungsi sesuai dengan rencana. Komponen yang di tes: 

Uji dilakukan pada sensor MAX30100 guna mengetahui saturasi oksigen, detak jantung, dan tekanan 

darah pasien sebelum dilakukan proses akupresure pada titik tangan pasien. 

 

2.7.2 Pengujian Keseluruhan Alat 

Pengujian alat secara keseluruhan dilakukan menggunakan komponen vibrator yang disimulasikan 

dalam alat capit tangan pada titik akupresure dengan dikendalikan oleh operator. Alat akan diujikan pada 

ibu hamil kala 1 sebanyak 6 orang. 
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III. HASIL DAN PEMBAHASAN 

Pada tabel dibawah adalah pengujian sensor MAX30100 dilakukan pada pasien dengan cara meletakkan ujung jari. 

Kemudian dilakukan perbandingan dengan alat standart untuk mendeteksi detak jantung dengan satu ukur BPM(Bet 

Per Minute), dan tekanan darah. Berikut hasil ukur pada tabel pengujian sensore MAX30100 

 

3.1 Pengujian Kalibrasi Detak Jantung 

Tabel 3.1 Pengujian Kalibrasi Detak Jantung 

No. 
Nama Alat 

Standart 

Pengukuran Selisih Perhitungan 

Sensor 

MAX30100 
Alat Standart Jumlah Selisih Pesentase (%) 

1. Omron HEM-

7121 Blood 

Pressure 

Monitor 

65 78 13 16,6% 

2. 69 95 26 27,3% 

3. 65 90 25 27,7% 

4. 68 78 10 12,8% 

 

 

3.2 Pengujian Tekanan Darah Kalibrasi 

Tabel 3.2 Pengujian Kalibrasi Tekanan Darah 

No. 
Alat Penelitian Alat Standart Selisih Error 

S D S D S D S D 

1. 119 73 121 88 3 15 - - 

2. 123 77 129 100 6 23 - - 

3. 119 73 118 84 1 11 - - 

4. 122 76 120 83 2 7 - - 

Keterangan : S = Sistolik 

    D = Diastolik 

 

3.3 Pengujian Pada Pasien RS. Rahman Rahim 

Tabel 3.3 Pengujian Vibrasi 

No. 

 

Tgl 

 

Nama Umur A B 
C 

(%) 

 

D 

1. 22/6/24 Suci Nur Aisyah 29th 138/90 135/90 100 7 

2. 22/6/24 Santy Indrawati 36th 108/70 112/70 100 5 

3. 22/6/24 Nining Wahyuni 38th 115/70 160/70 100 2 

4. 1/7/24 Shela Engelita 23th 112/68 113/60 100 5 

5. 1/7/24 Roudhotul Jannah 28th 134/88 129/83 100 4 

Keterangan : A = Tekanan darah awal pemeriksaan 

    B = Tekanan darah sesudah dilakukan vibrasi 

    C = Persentase vibrasi 

    D = Skor 1-10 nyeri yang ditanyakan ke pasien 

Hasil foto pengujian alat RS. Rahman Rahim 

 

 

 

 

 

 

 

 

 

 

 

 

 

Gambar 3.3 Pengujian Alat Pada RS. Rahman Rahim 
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IV. KESIMPULAN 

Dari hasil percobaan dan pengunjian alat dapat disimpulkan bahwa: 

 

Rancang alat yang digunakan untuk mengurangi rasa nyeri pada ibu hamil masih belum maksimal. Sebagian ada rasa 

sakit saat kontraksi tetapi sebagian lainya berkurang rasa sakit saat menggunakan alat. Waktu yang dibutuhkan 10-15 

menit penggunaan akupresure dari berapa kali terjadinya kontraksi hingga proses kelahiran berlangsung. Dari hasil 

pengukuran tekanan darah pasien dan detak jantung menglami perubahan yang belum maksimal. Hal ini dikarenakan 

output vibrasi pada alat masih terlalu kecil sehingga diperlukan vibrasi dengan output yang lebih besar agar alat 

bekerja maksimal dan lebih banyak pengujian terhadap pasien. Pengukuran tekanan darah awal saat kontraksi dan 

setelah dilakukan akupresure harusnya berkurang kisaran 5-10%, Sehingga pasien akan mengalami rileksasi dan 

berkurangnya rasa nyeri saat peredaran darah lancar dari dalam tubuh karena getaran yang dihasilkan alat pada titik 

akupresure. Alat ini berfungsi normal sebagaimana fungsinya, tampilan yang muncul pada layar LCD sesuai dengan 

hasil pengukuran dan akan mempermudah untuk mendata hasil pengukuran secara otomatis karena sudah dilengkapi 

dengan sistem IOT(Internet Of Things) dan 5 ID card untuk menyimpan data pasien ke dalam microsoft excel secara 

otomatis. 
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